Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 

Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 03-02-2021, 05:12 PM   #1
Junior Member
 
Brand: Thor Motor Coach
State: Georgia
Posts: 6
THOR #21016
No dash board power when engine running

Hi folks...I know this issue exists somewhere in the forum....sorry to duplicate
2017 23H Freedom Elite

My generator powers everything when on...Campgroud 30 amp powers everything when connected.....when I crank the engine there is no power to the radio or usb /power outlets/backup camera....

One person suggested the”battery relay switch” near storage batteries and another mentioned the PDS 5100 Automatic Transfer Switch....I assume one or both are underneath the coach??

Thanks very much in advance!!

Mike D
__________________

__________________
Mike D is offline   Reply With Quote
Old 03-02-2021, 11:25 PM   #2
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 ACE 30.1
State: Alberta
Posts: 1,185
THOR #2631
I see no responses to you so far, so you are stuck with me asking you to clarify some things. Are you saying that when on shore power (SP) everything including the radio works OK; then when you start the gen and it cuts over the transfer switch, everything including the radio works OK again;.......if true, this means your transfer switch is fine. It just transfers 120VAC from either SP or Gen to the input of the converter.

Then you start the engine and the radio shuts off? I think we all need some clarification or more details. By the way, the radio is usually powered from coach batteries.
__________________

__________________
javelin is offline   Reply With Quote
Old 03-03-2021, 09:48 AM   #3
Junior Member
 
Brand: Thor Motor Coach
State: Georgia
Posts: 6
THOR #21016
Quote:
Originally Posted by javelin View Post
I see no responses to you so far, so you are stuck with me asking you to clarify some things. Are you saying that when on shore power (SP) everything including the radio works OK; then when you start the gen and it cuts over the transfer switch, everything including the radio works OK again;.......if true, this means your transfer switch is fine. It just transfers 120VAC from either SP or Gen to the input of the converter.

Then you start the engine and the radio shuts off? I think we all need some clarification or more details. By the way, the radio is usually powered from coach batteries.
Tnx and sorry for confusion...Essentially the radio /dashboard outlets, backup cam only work when on shore power or generator.....they do not work on when the Coach engine is running or when using the “storage batteries “ switch.

Tnx again...I’ll check back later as I’m working shifts during this crazy time....
Mike D
__________________
Mike D is offline   Reply With Quote
Old 03-03-2021, 01:20 PM   #4
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 ACE 30.1
State: Alberta
Posts: 1,185
THOR #2631
No problem Mike, it is always best to provide as much information about the problem situation as you can so folks on the forum can try to better assist.

I am not familiar with your E450 chassis specifically, but usually the radio is powered from coach (house) batteries when the use/store switch is turned on, and the dash power receptacles (and probably associated usb plugs) typically powered from chassis (engine) battery. Others more familiar with E450 can correct that if required.

So when you say the radio does not work when “using storage battery switch”, you mean when you turn off the use/store switch correct? If true, that is normal. What is not normal is the radio and dash power outlets turn off when the engine is running. My first reaction to this situation is somehow the radio and dash receptacles are wired on an ignition lock out circuit in error. The lockout circuit relay prevents the slides or electric awning (or other devices) from being operated anytime the engine is running. Has this problem just started recently or has it always been a problem? Has anyone recently been working on the coach electrical system.....replaced any charging system components, etc.?
__________________
javelin is offline   Reply With Quote
Old 03-03-2021, 03:04 PM   #5
Junior Member
 
Brand: Thor Motor Coach
State: Georgia
Posts: 6
THOR #21016
Quote:
Originally Posted by javelin View Post
No problem Mike, it is always best to provide as much information about the problem situation as you can so folks on the forum can try to better assist.

I am not familiar with your E450 chassis specifically, but usually the radio is powered from coach (house) batteries when the use/store switch is turned on, and the dash power receptacles (and probably associated usb plugs) typically powered from chassis (engine) battery. Others more familiar with E450 can correct that if required.

So when you say the radio does not work when “using storage battery switch”, you mean when you turn off the use/store switch correct? If true, that is normal. What is not normal is the radio and dash power outlets turn off when the engine is running. My first reaction to this situation is somehow the radio and dash receptacles are wired on an ignition lock out circuit in error. The lockout circuit relay prevents the slides or electric awning (or other devices) from being operated anytime the engine is running. Has this problem just started recently or has it always been a problem? Has anyone recently been working on the coach electrical system.....replaced any charging system components, etc.?
Tnx ever so much for ur help this far....I purchased the coach recently...it has only 2K miles...the original owner says he never used the radio while driving...he streamed through headphones......
So when the coach is parked and engine off...The house batteries will not come on and operate anything....when connected to external power or generator, everything works great including the radio and dash outlets and backup camera.....no one has worked on the coach as far as I know....
I’ll check back after my shift.....Tnx!!!
Mike D
__________________
Mike D is offline   Reply With Quote
Old 03-03-2021, 03:35 PM   #6
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 ACE 30.1
State: Alberta
Posts: 1,185
THOR #2631
OK, that clarifies things a bit more. When you operate your use/store switch (SP disconnected and gen off) you don't get any 12vdc power from your coach batteries from the sound of it. Do you hear a click from a relay at all (may be under the hood), when you operate the use/store switch to "on" or "off"? Have you tested the voltage on your coach/house batteries with a voltmeter? If the coach battery voltage is too low, you likely won't be able to operate the use/store latching relay (assuming it is working OK) in order to charge them again off SP or generator. The use/store must be on to charge the coach batteries from SP or gen. So if the coach batteries are OK (full charge is approx 12.6vdc) then you may have a failed coach battery latching relay, bad connection somewhere; blown fusing related to the latching relay operation etc. If the coach batteries are discharged you will likely have to re-charge the coach batteries (assuming they will take a charge and are not damaged) with a regular battery charger to get things working properly again.
__________________
javelin is offline   Reply With Quote
Old 03-03-2021, 04:38 PM   #7
Junior Member
 
Brand: Thor Motor Coach
State: Georgia
Posts: 6
THOR #21016
Quote:
Originally Posted by Mike D View Post
Tnx ever so much for ur help this far....I purchased the coach recently...it has only 2K miles...the original owner says he never used the radio while driving...he streamed through headphones......
So when the coach is parked and engine off...The house batteries will not come on and operate anything....when connected to external power or generator, everything works great including the radio and dash outlets and backup camera.....no one has worked on the coach as far as I know....
I’ll check back after my shift.....Tnx!!!
Mike D
No, there is no relay clicking noise from under the coach or under the hood when the switch is used...both house batteries are fully charged...
__________________
Mike D is offline   Reply With Quote
Old 03-03-2021, 05:19 PM   #8
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 ACE 30.1
State: Alberta
Posts: 1,185
THOR #2631
OK Mike, so it is looking like you have a problem with the coach battery latching relay or the circuit used to operate and release that relay (a small associated fuse in the control circuit maybe, maybe poor connection, depending on what kind of charging circuit your coach uses). It could even be a bad use/store switch at the door or poor control connection at that switch. Some electrical trouble shooting is required.

Unfortunately I can’t advise you where to look on your coach for this latching relay or control fuse, but hopefully some other E450 owners will chime in here; or you could try contacting Thor tech (if they know). Sometimes factory installers find creative places to place electrical items. The other option is a mobile RV tech that might get you back in business faster for a reasonable cost. Sorry I can’t help you more.
__________________
javelin is offline   Reply With Quote
Old 03-03-2021, 07:46 PM   #9
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 ACE 30.1
State: Alberta
Posts: 1,185
THOR #2631
Just a followup comment. I noticed that Thor has a safety recall out for 2017-2021 Freedom Elite coaches per attached link. Since you have recently purchased this coach from a previous owner, if you contact Thor regarding the location of the coach disconnect latching relay, you should also confirm (or just look at the breakers yourself) that your coach has been corrected for any recalls to date. This one sounds like an important safety issue: breaker replacement to better match actual wiring ampacity.


https://www.consumeraffairs.com/reca...es-080420.html


I am also attaching a basic schematic showing a “generic” DC only (no AC shown) diagram of how a “typical latching relay” (right side of diagram) fits between coach batteries and the DC output of the converter. Note also the 50 amp resetable breaker in series with the latching relay. This may not be exactly how your coach is wired, but it should be similar in general function. If you trace cables from the coach battery you might be able to find the latching relay and breaker yourself). I was thinking about why your coach batteries are fully charged, even though it seems like your coach latching relay is failed open. I suspect that when you run your engine, the alternator is probably able to charge the coach batteries; but probably not the converter running off SP or Gen. Also if the coach loads cannot connect to the coach batteries......there is likely only parasitic loads draining the batteries.Good luck Mike.
Attached Thumbnails
Click image for larger version

Name:	Basic Generic Battery Schematic.jpg
Views:	14
Size:	126.6 KB
ID:	28886  
__________________

__________________
javelin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 10:21 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×