Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 12-27-2018, 06:30 PM   #1
Junior Member
 
DLFoust's Avatar
 
Brand: Jayco
Model: Entegra Vision 31V
State: Florida
Posts: 29
THOR #12040
Question No power to radio

The radio (Axxera AVM70) in our 2018 Vegas 24.1 was working when we left on our last outing. I turned it off when we got into heavy traffic, now it won't power up when I tried to turn it back on. I tried to reset it, no luck. The main switch by the door is on. The fuse marked audio/video in the back panel is fine and the radio in the bedroom still works. The USB and 12v power port under the radio are not working either. Anyone got any ideas before I take it in for service?
__________________

__________________
DLFoust is offline   Reply With Quote
Old 12-27-2018, 06:43 PM   #2
Senior Member
 
Brand: Thor Motor Coach
Model: 2015 Vegas 25.2
State: Oregon
Posts: 907
THOR #2271
I've had the same issue. There is yet another fuse box in the engine compartment. Check Ed's manual for the location of the fuse that controls the in-dash radio. On my E-350 chassis, it was #70
__________________

__________________
Added: HWH Kick-Down Leveler; RoadMaster Anti-sway bars; Tornado Rotary Tank Rinser; Accede Backup Sensor Kit; cylinder locks (w/one combo lock); custom sink cover; Kenwood DDX 5706S front radio; Pioneer MVH-X5560BT rear radio; Oxygenics Shower head; ScanGuage II; Blue Ox Tow Bar w/RVi Brake 2; Winegard Rayzar Automatic TV antenna; Trimark Steel door lock; Dometic 310 toilet; whatever is next.
gbrown is offline   Reply With Quote
Old 12-27-2018, 06:47 PM   #3
Junior Member
 
DLFoust's Avatar
 
Brand: Jayco
Model: Entegra Vision 31V
State: Florida
Posts: 29
THOR #12040
Thanks for the reply. I'll check it out. Hope that I find something.
__________________
DLFoust is offline   Reply With Quote
Old 12-27-2018, 07:46 PM   #4
Junior Member
 
DLFoust's Avatar
 
Brand: Jayco
Model: Entegra Vision 31V
State: Florida
Posts: 29
THOR #12040
On my E450 chassis the #70 fuse in the engine compartment fuse box is empty. In the Ford owners manual it shows that for the "stripped chassis". While I was in there I checked the #72 fuse marked "Cigarette lighter/power point". I was good also. Next I found another fuse box down by the brake pedal. It had fuse #39 marked "radio". I was good.
Starting to get over my head on this fix.
__________________
DLFoust is offline   Reply With Quote
Old 12-27-2018, 08:03 PM   #5
Senior Member
 
Rich&Cathy's Avatar
 
Brand: Thor Motor Coach
Model: Ace 29.3
State: California
Posts: 192
THOR #6522
Quote:
Originally Posted by DLFoust View Post
On my E450 chassis the #70 fuse in the engine compartment fuse box is empty. In the Ford owners manual it shows that for the "stripped chassis". While I was in there I checked the #72 fuse marked "Cigarette lighter/power point". I was good also. Next I found another fuse box down by the brake pedal. It had fuse #39 marked "radio". I was good.
Starting to get over my head on this fix.
Is your use/store switch in the use position?
__________________
Rich&Cathy is offline   Reply With Quote
Old 12-27-2018, 08:06 PM   #6
Junior Member
 
DLFoust's Avatar
 
Brand: Jayco
Model: Entegra Vision 31V
State: Florida
Posts: 29
THOR #12040
Quote:
Originally Posted by Rich&Cathy View Post
Is your use/store switch in the use position?
Yes, the switch is on. All the other 12v items are working.
__________________
DLFoust is offline   Reply With Quote
Old 12-28-2018, 04:39 PM   #7
Junior Member
 
DLFoust's Avatar
 
Brand: Jayco
Model: Entegra Vision 31V
State: Florida
Posts: 29
THOR #12040
Smile Fuse Found

With help from schematic drawings that Thor emailed to me, I was able to determine that the radio is fed directly from the battery, yellow wire with a 15A inline fuse. I searched around and found a yellow wire with an inline fuse attached to the battery isolation manager (BIM), under the hood. The 15A fuse was bad so I replaced it and the radio has power again. The attached picture shows the BIM with the yellow wire and inline fuse.
Attached Thumbnails
Click image for larger version

Name:	BIM.jpg
Views:	209
Size:	67.0 KB
ID:	14787   Click image for larger version

Name:	BIM2.JPG
Views:	155
Size:	21.3 KB
ID:	14788  

__________________
DLFoust is offline   Reply With Quote
Old 12-29-2018, 01:34 AM   #8
Senior Member
 
Brand: Thor Motor Coach
Model: Windsport. 35M
State: New York
Posts: 281
THOR #6199
Nice job. One thing to keep in mind is that many of these radios require two power feeds. One actually runs the radio. The other one keeps the memory settings. They both have to have power for the system to run.
__________________
Shawn
2017 Windsport 35M
Shawn62 is offline   Reply With Quote
Old 12-29-2018, 02:22 AM   #9
Senior Member
 
Brand: Thor Motor Coach
Model: 2016 Thor Outlaw 29H
State: Tennessee
Posts: 435
THOR #13869
That is great you found that, and thanks for sharing, with pictures too.
__________________
10scDust is offline   Reply With Quote
Old 12-29-2018, 02:59 PM   #10
Junior Member
 
DLFoust's Avatar
 
Brand: Jayco
Model: Entegra Vision 31V
State: Florida
Posts: 29
THOR #12040
Radio Memory

Quote:
Originally Posted by Shawn62 View Post
Nice job. One thing to keep in mind is that many of these radios require two power feeds. One actually runs the radio. The other one keeps the memory settings. They both have to have power for the system to run.
After looking at the circuit list again, you are correct that it is the memory circuit that had the blown fuse. Now I want to know why the fuse blew in the first place????
Thanks for the reply!
Attached Thumbnails
Click image for larger version

Name:	12V Circuits.JPG
Views:	176
Size:	31.5 KB
ID:	14804  
__________________
DLFoust is offline   Reply With Quote
Old 12-29-2018, 04:31 PM   #11
Senior Member
 
Brand: Thor Motor Coach
Model: Windsport. 35M
State: New York
Posts: 281
THOR #6199
You are welcome. My radio is The Axxera AV615BHM so I wasn’t sure if it would be the same. When my radio quit it was a bad/loose pin in the wiring harness connector. When I removed the radio, I found many loose/badly crimped butt connectors. I found a hot wire hanging out in open space just waiting to short on something. I just cut it back and taped it. I did not have any blown fuses. My camera feed to the back of the radio is loose again but I am going put a monitor on the dash instead.
__________________
Shawn
2017 Windsport 35M
Shawn62 is offline   Reply With Quote
Old 01-19-2019, 01:46 AM   #12
Member
 
Brand: Thor Motor Coach
Model: Quantum
State: Alabama
Posts: 47
THOR #13457
Quote:
Originally Posted by DLFoust View Post
On my E450 chassis the #70 fuse in the engine compartment fuse box is empty. In the Ford owners manual it shows that for the "stripped chassis". While I was in there I checked the #72 fuse marked "Cigarette lighter/power point". I was good also. Next I found another fuse box down by the brake pedal. It had fuse #39 marked "radio". I was good.
Starting to get over my head on this fix.
I am having the same problem with my Quantam. Can't find fuses that are blown.
__________________
tinker3030 is offline   Reply With Quote
Old 01-19-2019, 02:17 PM   #13
Junior Member
 
Lemo's Avatar
 
Brand: Thor Motor Coach
Model: Windsport 31S
State: Arizona
Posts: 18
THOR #11853
Had a similar problem on mine after not using it for awhile. There is a reset button on the radio which looks like a small hole on the left side of the radio about half way down from the on off button. Using the tip of a ball point pen I pushed it in and that reset the radio functions. Worked for me on my 2018 Thor Windsport. Hope this helps.
__________________
Lemo is offline   Reply With Quote
Old 01-31-2019, 01:35 PM   #14
Senior Member
 
Brand: Thor Motor Coach
Model: 25.2 axis
State: South Carolina
Posts: 170
THOR #3992
No power to radio

Was just going through some old questions on the form and came across yours .Just recently had same problem no 12 volt to the dash radio power outage nothing was working. My fuse was in a holder the driver seat front next to the factory fuse box at Ford puts in. Mine had a 35 amp. The video transfer switch was causing it to blow which is directly under the dash in front of the steering wheel. Guess they're all put together a little different.
__________________
nautiquecowboy is offline   Reply With Quote
Old 02-16-2019, 10:34 PM   #15
Junior Member
 
Brand: Thor Motor Coach
State: California
Posts: 5
THOR #6717
Had the same issue on my Quantum. To kill the power to the radio, I pulled both fuses, then put them back and then pushed the reset button and it now works.
__________________
foxenter is offline   Reply With Quote
Old 06-11-2019, 09:25 PM   #16
Junior Member
 
Brand: Thor Motor Coach
State: Alabama
Posts: 20
THOR #14401
Hi There, where can I find Ed's manual?

Dee
__________________
topd65 is offline   Reply With Quote
Old 06-11-2019, 09:56 PM   #17
Senior Member
 
Brand: Thor Motor Coach
Model: 25.2 axis
State: South Carolina
Posts: 170
THOR #3992
Quote:
Originally Posted by DLFoust View Post
The radio (Axxera AVM70) in our 2018 Vegas 24.1 was working when we left on our last outing. I turned it off when we got into heavy traffic, now it won't power up when I tried to turn it back on. I tried to reset it, no luck. The main switch by the door is on. The fuse marked audio/video in the back panel is fine and the radio in the bedroom still works. The USB and 12v power port under the radio are not working either. Anyone got any ideas before I take it in for service?
Driver side front drop your engine access panel look on the right side you'll see a fuse holder separate just kind of hanging there has a 30 amp fuse that works the radio and those 12 volt Outlets. That's where mine was at it was blown.
__________________

__________________
nautiquecowboy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 06:44 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×