RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
 

Go Back   Thor Forums > Thor Tech Forums > Motorhome Tech Topics
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 05-04-2017, 03:02 AM   #1
Senior Member
 
Brand: Still Looking
Model: Newmar Bay Star Sport 300
State: Alabama
Posts: 3,045
THOR #6826
Can anyone help me identify a noise?

My 2017 Freedom Elite on a Ford E-450 chassis sometimes has a fairly loud intermittent clicking sound coming from under the hood. It only occurs sometimes and only when the engine is running. Vehicle does not have to be moving or in gear. Today while it was happening I got out and opened the hood. It sounds like a relay clicking and or is coming from up behind the brake booster. Can anyone tell me what this might be? It does not sound "proper"!

Thank you.
__________________

__________________
Pete'sMH is online now   Reply With Quote
Old 05-04-2017, 03:12 AM   #2
Member
 
Woofwoof's Avatar
 
Brand: Thor Motor Coach
Model: Hurticane 34J
State: Massachusetts
Posts: 36
THOR #1987
Did you have the dash AC or defroster on? Could be the ac compressor coming on. Perfectly normal click when the compressor engages. You can see the front of the pulley start spinning when the compressor comes on. Will come on and off intermittently.
__________________

__________________
Woofwoof is offline   Reply With Quote
Old 05-04-2017, 04:35 AM   #3
Senior Member
 
Brand: Still Looking
Model: Newmar Bay Star Sport 300
State: Alabama
Posts: 3,045
THOR #6826
No, wasn't on and it's not in that area. Definitely up behind the brake fluid reservoir. Also when it happens it's like it chatters randomly, sometimes rather rapidly sometimes not. Today it happened only after driving about 300 miles. Appreciate the response. Of course it doesn't do it when at the dealers!
__________________
Pete'sMH is online now   Reply With Quote
Old 05-04-2017, 10:24 PM   #4
Senior Member
 
Ewok's Avatar
 
Brand: Thor Motor Coach
Model: Windsport 34P
State: Arizona
Posts: 127
THOR #5872
electeric fan

Does it have a electric fan? might need replaced if it over heats it will try and cycle. Hope this helps
__________________
Alan
US Navy E5
Vietnam Vet
Retired mechanic
Ewok is offline   Reply With Quote
Old 05-05-2017, 08:08 PM   #5
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 31L
State: Florida
Posts: 1,989
THOR #908
mine is an E-450 chassis. Thor put the house battery / chassis battery isolating relay....along with the Intellitec B.I.R.D in that area just under the brake master cylinder.

I recently replaced the relay, so I am familiar....

clicking on and off indicates battery voltage falling below 12.6V when plugged in or when engine is running. This is normal with heavy loads or with low batteries
__________________
blw2 is offline   Reply With Quote
Old 05-05-2017, 08:10 PM   #6
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 31L
State: Florida
Posts: 1,989
THOR #908
http://intellitec.com/assets/pdf/145...-00362-000.pdf
__________________
blw2 is offline   Reply With Quote
Old 05-06-2017, 03:40 AM   #7
Senior Member
 
Brand: Still Looking
Model: Newmar Bay Star Sport 300
State: Alabama
Posts: 3,045
THOR #6826
Thank you blw2. Might be on to something here. After driving for 6 hours today I noticed that the house battery is showing 3/4 charge. After being plugged into shore power it's still showing the same after unplugging (it shows full while on shore power). Perhaps my original factory battery is failing to hold a proper charge. I don't have a voltmeter out on the road - I'm a LONG way from home at Zion in Utah at the moment. It's something to check! Coach was made last August but sometimes batteries fail....
__________________
Pete'sMH is online now   Reply With Quote
Old 05-06-2017, 12:23 PM   #8
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 31L
State: Florida
Posts: 1,989
THOR #908
yes they sure do. I learned the hard and expensive way, over many years with boats and my old popup. And found that the battery in my MH was DOA when I bought the coach new.
These things are damaged by deep discharge, and I think what happens often, as what I'm sure is what happened in the case of my MH....
the RV sits on the lot for a while, and the battery gets drained
either by self discharge over time, &/or by folks leaving the "use" switch connected, maybe a light left on over night, etc.....
It might sit dead for a day or more, then get recharged
One, two, or more cycles like this kill the battery.
It might hold enough charge when recharged to look ok for a PDI
but it's really no good at all.

The very first thing I did on mine was to install battery post disconnect switches on my chassis and house batteries. When I park the thing, I always disconnect them so that there is zero chance for parasitic loads to drain them. Now all I have to worry with is the self discharge that happens over time.
They last a lot longer than they did in my popup.

I found that my isolating relay was bad a few weeks ago, when I discovered that after a long drive my house battery was only partially charged, and barely made it through the night of light use. I was at the Sun n Fun fly-in, and found a vendor selling aircraft grade contactors so I was able to replace it right away...but I'm afraid my battery was probably harmed....so I'll prob. be buying a new battery soon.

edit: now I know to listen for that click regularly to make sure it's working
__________________
blw2 is offline   Reply With Quote
Old 05-07-2017, 02:25 AM   #9
Senior Member
 
Brand: Still Looking
Model: Newmar Bay Star Sport 300
State: Alabama
Posts: 3,045
THOR #6826
I really appreciate the clue. I'm still a week from home but I noticed that after today's 8 hour drive my panel still only shows 2/3 charge on my battery unless hooked up to shore power. So where exactly did Thor mount the relay? On the firewall under the hood or inside the cab? (It's been pouring rain and I haven't really looked yet....)

I'd love to take my coach to Sun n Fun! I'm an 88 hour sport pilot who built a titan tornado a few years back.
__________________
Pete'sMH is online now   Reply With Quote
Old 05-07-2017, 03:11 AM   #10
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 31L
State: Florida
Posts: 1,989
THOR #908
Mine is under the hood, mounted on the fender near the firewall, just under the coolant bottle and very near the brake cylinder.
This is what was in mine from the factory
https://www.amazon.com/Trombetta-Vol.../dp/B00K7DSQ4C
and mounted nearby was the Intellitec delay relay,sorta like this one but not exactly
Products - DC Power Management - Intelligent battery charging - The BIRD
__________________
blw2 is offline   Reply With Quote
Old 05-07-2017, 12:42 PM   #11
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 31L
State: Florida
Posts: 1,989
THOR #908
I don't know if you have this same one or not, but attached is the manual for the relay delay unit I have

I was thinking about your question.... specifically this has reminded me that I never went back and tested all the functions of my unit since I replaced the contractor...and specifically I need to verify if the emergency start function is still working. I don't think it's pulling in the relay but I need to check. There's a fuse on that circuit that may be blown....

Anyway, I was looking over this manual again and thought you might find it interesting too.
Attached Files
File Type: pdf Alternator Charge House Battery BIRD.pdf (101.2 KB, 61 views)
__________________
blw2 is offline   Reply With Quote
Old 05-19-2017, 04:06 AM   #12
Senior Member
 
Brand: Still Looking
Model: Newmar Bay Star Sport 300
State: Alabama
Posts: 3,045
THOR #6826
Blw2 - thought I'd follow up now that I'm home from a great 4000 mile trip. I appreciate your help and I think you've got me on the right track. I put the awning out to dry when we got home and found that my battery didn't have the juice to bring it back in until I connected to shore power. Took the battery out and charged it on the bench and then took it to Batteries Plus where it tested fine. Notwithstanding, something is going on here. I want to check the chassis ground connection next.
__________________

__________________
Pete'sMH is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 03:08 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×