Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 09-13-2020, 06:43 PM   #1
Senior Member
 
Down South's Avatar
 
Brand: Thor Motor Coach
Model: A.C.E 27.2
State: Louisiana
Posts: 112
THOR #17883
Axxera rearview camera quit working

On my 2017 Thor Ace the backup or rearview camera quit working. My radio is the Axxera AVM80.
The camera was working fine when I pulled into a park and stayed for a few days. The camera worked well as I use it to monitor my trailer going down the road and it was working when I backed into a site at the campground.

The morning that I decided to leave the camera was inoperable. I get a message "No Video Signal".
Both of my side cameras work so I know the connection to the radio is good.

I checked connections at the switch box. I accessed the camera connection at the rear of the MH. I took the connections apart and put them back together.
I rebooted the radio by shutting off shore power and putting the coach in store mode then rebooting.
I found new firmware for the radio and installed that. Still no backup camera.

Does anyone have an idea of something that I have not tried?
Maybe the camera went bad?
__________________

__________________
2017 Thor ACE 27.2
Down South is offline   Reply With Quote
Old 09-13-2020, 06:49 PM   #2
Junior Member
 
Brand: Thor Motor Coach
State: California
Posts: 9
THOR #17745
I had a similar thing happen, camera working fine then all of a sudden it stopped. It ended up being the a/v connection behind the radio head.

I removed the radio head, reconnected the loose cables and everything was working again. No issues since.

2017 Thor Hurricane
__________________

__________________
Land Cruisin is offline   Reply With Quote
Old 09-13-2020, 07:10 PM   #3
Senior Member
 
Down South's Avatar
 
Brand: Thor Motor Coach
Model: A.C.E 27.2
State: Louisiana
Posts: 112
THOR #17883
I only have one connection going to the radio from the switch box. The other two cameras show up on the radio so the connection at the radio is good.
__________________
2017 Thor ACE 27.2
Down South is offline   Reply With Quote
Old 09-29-2020, 01:57 AM   #4
Senior Member
 
Down South's Avatar
 
Brand: Thor Motor Coach
Model: A.C.E 27.2
State: Louisiana
Posts: 112
THOR #17883
Thought that I'd come back to tell the rest of the story.
Doing more troubleshooting, I disconnected the feed from the RV camera from the switch box and hooked the right side camera to that input. When switched to the rear camera, the right side camera came up on the screen.
I hooked the RV feed to the right side camera connection on the switch and it displayed, no video signal.
So the problem was either the cable for the RV camera or the camera. I ordered a new camera from RVS with 60+ feet of new cable.

It was the camera. New camera works like a new camera.


What was strange is the old camera worked great backing into my site at a state park. Spent three days and the camera was dead when it came time to leave.
__________________
2017 Thor ACE 27.2
Down South is offline   Reply With Quote
Old 10-18-2020, 03:50 PM   #5
Junior Member
 
Brand: Thor Motor Coach
Model: four winds 30W
State: Virginia
Posts: 11
THOR #9584
Angry cameras not working

2018 31w, Axxera radio. My Radio and along with it rear camera and outside mirror cameras are now blank. NADA. check the under hood fuse: OK. Check the panel fuse: OK. Any ideas that would cause radio and cameras to die?
__________________
caution is offline   Reply With Quote
Old 10-18-2020, 04:36 PM   #6
Senior Member
 
Brand: Thor Motor Coach
Model: Hurricane 35m
State: North Carolina
Posts: 197
THOR #13505
made in china, planned obsolescent

Nice job on figuring it out. Ours had to be replaced on 2020 rig, did crap install on orginal.
__________________
Retired Squid who has a retired squid that drives him around in a RV!
macdaddy1111 is offline   Reply With Quote
Old 10-18-2020, 05:02 PM   #7
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 5,053
THOR #7035
Quote:
Originally Posted by caution View Post
2018 31w, Axxera radio. My Radio and along with it rear camera and outside mirror cameras are now blank. NADA. check the under hood fuse: OK. Check the panel fuse: OK. Any ideas that would cause radio and cameras to die?
I gotta ask the question: Status of your battery disconnect switch? The radio is powered from the house batteries. No power = no radio and no cameras.
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
2020 Chevy Colorado Z71 Trail Runner Alternate Toad
16ACE27 is offline   Reply With Quote
Old 10-19-2020, 01:01 PM   #8
Junior Member
 
Brand: Thor Motor Coach
Model: four winds 30W
State: Virginia
Posts: 11
THOR #9584
Radio, cameras ZIP

Yes master switch on. Nothing travelling down the road or hooked up to cg electric. Just nothing.
__________________
caution is offline   Reply With Quote
Old 10-19-2020, 01:34 PM   #9
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 5,053
THOR #7035
Quote:
Originally Posted by caution View Post
Yes master switch on. Nothing travelling down the road or hooked up to cg electric. Just nothing.
One more Hail Mary: Have you tried resetting the radio with the reset switch on the front panel through the really tiny hole?
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
2020 Chevy Colorado Z71 Trail Runner Alternate Toad
16ACE27 is offline   Reply With Quote
Old 10-19-2020, 02:27 PM   #10
Junior Member
 
Brand: Thor Motor Coach
Model: four winds 30W
State: Virginia
Posts: 11
THOR #9584
Thumbs up

Quote:
Originally Posted by 16ACE27 View Post
One more Hail Mary: Have you tried resetting the radio with the reset switch on the front panel through the really tiny hole?
WHOA AND WHEE!!!! Although the manual does not describe the reset button I did find it and as soon as I pressed the reset the radio and camera came back on. Thank you so very much. God bless and keep on RVing!
__________________
caution is offline   Reply With Quote
Old 10-19-2020, 02:30 PM   #11
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 5,053
THOR #7035
Quote:
Originally Posted by caution View Post
WHOA AND WHEE!!!! Although the manual does not describe the reset button I did find it and as soon as I pressed the reset the radio and camera came back on. Thank you so very much. God bless and keep on RVing!
GREAT!

Much better than having to replace the radio.
__________________

__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
2020 Chevy Colorado Z71 Trail Runner Alternate Toad
16ACE27 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 10:46 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×