Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 12-21-2019, 11:58 AM   #1
Junior Member
 
Brand: Thor Motor Coach
State: Pennsylvania
Posts: 6
THOR #16577
Exclamation Magnum inverter issue

2017 Thor Tuscany with Magnum inverter. Charger seems to be acting up. I am plugged into 50amp shore power. Batteries were showing low so I did a hard system reset. Batteries started charging nicely. First Bulk charge then system went to absorption charge as I would expect. OK so I went to bed. Got up at 5am when I noticed that the wife was making coffee and the bedroom fan slowed down. Checked and No Charge again. Shut down inverter and restarted at keypad in RV. inverter came back on and it went back on to Bulk charge and now on absorption charge.
Also maybe connected or not to the issue...Water level indicator is fluctuating from 0-75%...Odd.
any Idea why this is happening? How to troubleshoot?
__________________

__________________
ggribble is offline   Reply With Quote
Old 12-22-2019, 06:13 AM   #2
Senior Member
 
Brand: Thor Motor Coach
Model: Palazzo 33.2
State: California
Posts: 247
THOR #12839
If you are able to take a picture of your Firefly control panel and post it, we may be able to see some information that might help.
__________________

__________________
2018 Palazzo 33.2
HaRVey is offline   Reply With Quote
Old 12-22-2019, 11:50 AM   #3
Thor Palazzo 33.3 diesel
 
TurnerFam's Avatar
 
Brand: Thor Motor Coach
Model: Palazzo 33.3 34'bunkhouse
State: Georgia
Posts: 2,344
THOR #4735
sounds like a 'control' issue where maybe the system is losing power to the Inverter/Charger unit, even momentarily, causing it to shut down. Even then you'd still have flow-thru power to your outlets, but you'd have no Charging.

I started to see this happen to ours several years ago. Any slight 'bump' in a power need, such as the fridge kicking on, would suddenly cause the Inverter to shut down, when not on Shore Power.

Ultimately, several bad cells in one of the four 6v House batteries was the culprit. The slight 'load' caused the battery bank to 'drop' below 12v output, even for a spit second, and then the Inverter would 'think' it had no power, and therefore would shut down and the screen would go blank.
Repairing the cells(or replacing the battery), solved the problem.
__________________
the Turners
'14 Palazzo 33.3 bunkhouse 34' diesel
KingTailgater2 Dish HD, 100w/5a SOLAR, BlueOx
100,000+mi since '14 - US, Alaska, Canada - Hiawassee, GA! (also, '14 Gulfstream Amerilite and '07 ForestRiver Rockwood) : )
TurnerFam is online now   Reply With Quote
Old 12-28-2019, 09:56 PM   #4
Junior Member
 
Brand: Thor Motor Coach
Model: ARIA 3901
State: Texas
Posts: 9
THOR #13013
3901 aria
OneHouse battery had a bad cell causing system complications

RePlaced the batteries all was working good but then the inverter started acting up at first it was not signaling itself on checking the connections seem to solve that problem

I’m now experience another issue, water pump sometimes will not come on and it’s a new pump bench checked it with a 12 V battery runs fine and my AirXCell water heater system is not operating even thought it shows it’s calling for heat activation with the light

Still working on this problem

Will post for others to reply to
__________________
330jetjoc is offline   Reply With Quote
Old 12-29-2019, 04:12 PM   #5
Senior Member
 
Brand: Thor Motor Coach
State: Missouri
Posts: 618
THOR #6903
Quote:
Originally Posted by ggribble View Post
2017 Thor Tuscany with Magnum inverter. Charger seems to be acting up. I am plugged into 50amp shore power. Batteries were showing low so I did a hard system reset. Batteries started charging nicely. First Bulk charge then system went to absorption charge as I would expect. OK so I went to bed. Got up at 5am when I noticed that the wife was making coffee and the bedroom fan slowed down. Checked and No Charge again. Shut down inverter and restarted at keypad in RV. inverter came back on and it went back on to Bulk charge and now on absorption charge.
Also maybe connected or not to the issue...Water level indicator is fluctuating from 0-75%...Odd.
any Idea why this is happening? How to troubleshoot?
Since you haven't been back on did you get this fixed?

I would be suspect of a battery or connection which is where I would check and test first
__________________
lwmcguire is offline   Reply With Quote
Reply

Tags
magnum inverter trouble

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 02:25 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×