Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 09-21-2020, 02:49 PM   #1
Junior Member
 
Brand: Thor Motor Coach
Model: ACE 30.1
State: Florida
Posts: 4
THOR #2524
Generator Issue

Have a 2014 ACE, Generator has always been fine until recently. Problem now is it starts and runs fine until as long as coach is moving. Upon arrival at destination, turns off after just a couple of minutes usually during check in at campground.. Wonít restart till after complete cooldown.. Is there some sort of thermal sensor going on? Anyone ever experience this..?
__________________

__________________
Brentwood is offline   Reply With Quote
Old 09-21-2020, 03:22 PM   #2
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 5,044
THOR #7035
What code do you get? Sounds like maybe a cooling problem. Mice nest in the cooling shroud path?
__________________

__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
2020 Chevy Colorado Z71 Trail Runner Alternate Toad
16ACE27 is offline   Reply With Quote
Old 09-21-2020, 03:30 PM   #3
Senior Member
 
Brand: Thor Motor Coach
Model: Siesta 24SS
State: California
Posts: 773
THOR #12698
You might also check your generator oil level. If it is low it will shut off automatically.


Paul
__________________
paulwadley is offline   Reply With Quote
Old 09-21-2020, 04:43 PM   #4
Junior Member
 
Brand: Thor Motor Coach
Model: ACE 30.1
State: Florida
Posts: 4
THOR #2524
I think I saw 4 quick flashes when tried to restart, but then went back to check after setup and flash codes were gone... I definitely inspected everything with shroud cover off..
__________________
Brentwood is offline   Reply With Quote
Old 09-21-2020, 04:47 PM   #5
Junior Member
 
Brand: Thor Motor Coach
Model: ACE 30.1
State: Florida
Posts: 4
THOR #2524
Oil level was fine Paul, restarts and runs perfectly after cool down as long as we’re moving down the road, have run for 6hrs straight or even just 45 minutes, same thing happens...
Thanks
__________________
Brentwood is offline   Reply With Quote
Old 09-26-2020, 01:11 PM   #6
Junior Member
 
Brand: Thor Motor Coach
State: Nebraska
Posts: 10
THOR #17133
Generator

Started up my generator to make sure it was working. A flashing red light came on, on the indoor panel. The gen ran but it would not put out power to run any appliances. I turned it off, and it would not restart since the battery was to low.
__________________
dubh is offline   Reply With Quote
Old 09-26-2020, 03:13 PM   #7
Senior Member
 
Brand: Thor Motor Coach
Model: Citation
State: Texas
Posts: 385
THOR #8139
Quote:
Originally Posted by dubh View Post
Started up my generator to make sure it was working. A flashing red light came on, on the indoor panel. The gen ran but it would not put out power to run any appliances. I turned it off, and it would not restart since the battery was to low.
"it would not restart since the battery was to low"

I was taught as a repairman to always fix the easy stuff first.
Fix your low battery, then retest.
__________________

__________________
abjbrtd is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 08:32 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×