Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 09-05-2020, 11:58 PM   #1
Member
 
Brand: Thor Motor Coach
State: Utah
Posts: 36
THOR #12702
HELP battery and fuse problem

I removed the battery from our Freedom Elite (2017) 29 ft to charge, when re-installing apparently a fuse blew as I have no power to the control box for the gen or the other functions on the box. the engine starts and runs well when the battery and the connections are not hooked up but upon hooking the connections the motor home engine stutters and almost wants to stop and then start again. I have disconnected the cables to the battery and the engine runs but with no power to lights, gen and other things. I know the fuse panel is in the bedroom at the end of the bed but with no power to the slide outs I can't get to the fuse box. Anyone have a suggestion as what to do. The cables to the battery are three red ends and one yellow. when removing them off and putting them back on the three red went to pos and the yellow was neg. any idea's accepted.

__________________
cramar is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 01:34 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2