Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 09-12-2020, 02:24 PM   #1
Junior Member
 
Brand: Thor Motor Coach
Model: Chateau 31A
State: Minnesota
Posts: 2
THOR #20475
Not sure why backup camera doesn't work (2014 Thor Chateau)

I have recently purchased a 2014 Thor Chateau 31A and after picking up the RV, I noticed that nothing was working electrically, including the Panasonic AVH-P1400DVD on the dash. After resetting the circuit breakers, everything started working again except the dash was beeping and not turning on. I then removed the fuse to the dash and replaced it, and that seemed to do the trick. However, when I tried to use the backup camera (C1000M-13375) the display showing up on the dash was black and white and flickering really poorly. After a few days, I no longer can see anything from the backup camera.

Has anyone seen this issue before? Do you think it's related to the circuit breakers resetting? Or do you think it's something wrong with the camera? I'm also trying to reach the previous owner to understand if the camera was working before he sold it to me.

__________________
riceball.ontheroad is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 01:01 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2