Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 08-08-2020, 05:53 PM   #1
Junior Member
 
Brand: Thor Motor Coach
Model: Windsport 34J
State: New Jersey
Posts: 15
THOR #5481
Radio and backup camera problem

For whatever reason, we cannot get the radio or backup camera to work while we're actually driving the RV. Parked? Radio comes in no problem, but long drives without tunes is hard. It did work at one time, but it's been inconsistent for years. We've made sure it's in USE and hit the reset... Nothing. Thoughts?

__________________
HunterLa is offline   Reply With Quote
Old 08-09-2020, 12:30 PM   #2
Junior Member
 
Brand: Thor Motor Coach
State: Michigan
Posts: 3
THOR #15903
Axxera Radio

Quote:
Originally Posted by HunterLa View Post
For whatever reason, we cannot get the radio or backup camera to work while we're actually driving the RV. Parked? Radio comes in no problem, but long drives without tunes is hard. It did work at one time, but it's been inconsistent for years. We've made sure it's in USE and hit the reset... Nothing. Thoughts?
I would try uploading a firmware update to your Radio:

Product Firmware Updates
__________________
rincon2k is offline   Reply With Quote
Old 08-09-2020, 01:25 PM   #3
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 9,811
THOR #7035
What have you done to troubleshoot it?

The radio needs 12 VDC from the house DC buss.

The house DC buss receives 12 VDC from the house battery bank through the USE/STORE switch and the 50 amp DC breaker, or from the converter, or from the chassis battery/alternator through the BIRD/BIM.

So you say it doesn't work when driving but works when parked. Does it work when parked without being plugged into SP? Does the fridge work when the radio doesn't?
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
2020 Chevy Colorado Z71 Trail Runner Alternate Toad
16ACE27 is offline   Reply With Quote
Old 08-09-2020, 01:50 PM   #4
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 ACE 30.1
State: Alberta
Posts: 1,382
THOR #2631
Not familiar with your coach specifically, but from your description it sounds like the radio and back up camera work fine when in park with engine running? If yes then it is not likely any interlock relay power removal situation or wiring error related to lockouts. Then the radio and camera quit working when you move shifter into any forward gears.......what about into reverse gear?
Assuming no one has recently modified wiring in your coach, it sounds like moving the shifter is possibly somehow mechanically moving the radio power wiring (+12vdc or ground) somehow to kill power to the radio. Check the radio physical wiring terminations for any loose connections.....both on the radio and on fuse panel feeding the radio as well. Maybe there is a wiring splice (power or ground) feeding the radio that is also physically being moved (loose splice connection) by shifting into gear?
__________________
javelin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 07:23 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2