Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 10-24-2018, 11:27 PM   #1
Junior Member
 
Brand: Thor Motor Coach
Model: Axis
State: Colorado
Posts: 4
THOR #1871
2015 Thor Axis 24.1 Monitor Panel

Just got back from a weekend camping. Ran out of water. Water pump will not come on, but the Surflo pump is supposed to be able to run dry without damage. Fuse is good. When the water pump switch is turned on at the monitor panel, red indicator light does not come on. Also, the red LED indicator lights for the LPG, battery, & holding tank levels just blink on, then off, and will not come back on. Wait several minutes, push any of the buttons, the lights blink and go off again.
Generator start switch works, slide extend switch works, overhead bunk switch works, tank heater switches work. In addition, the light and fan on the stove hood will not work now. Checked all fuses, all good. Use/store switch works. This is driving me crazy. Any ideas out there?
__________________

__________________
Finskidog is offline   Reply With Quote
Old 10-25-2018, 02:34 AM   #2
Member
 
Brand: Thor Motor Coach
Model: Vegas 24.1
State: Washington
Posts: 63
THOR #10717
You have a loose wire connection on your circuit breaker box that is located underneath the refrigerator. I had the same exact issue with my RV. If you want you can take the cover off the circuit breaker box and tighten all the binding posts and that should fix it
__________________

__________________
gte534j is offline   Reply With Quote
Old 10-25-2018, 01:42 PM   #3
Junior Member
 
Brand: Thor Motor Coach
Model: Axis
State: Colorado
Posts: 4
THOR #1871
gte534j: Thanks! I'll see what I can do and let you know.
__________________
Finskidog is offline   Reply With Quote
Old 10-26-2018, 08:45 PM   #4
Junior Member
 
Brand: Thor Motor Coach
Model: Axis
State: Colorado
Posts: 4
THOR #1871
Finskidog's monito panel problem

gte534j: I took the cover off the breaker panel and checked all the wires. They were all good. Because the little red indicator light was not on at the water pump fuse, I assumed the fuse was good and did not look close at it. I took it out and looked at it again, was really hard to see that it was burned out, but it was. The red indicator light at this fuse does not work. I replaced the fuse and now everything works. So that was the problem. But, the frustrating part is that the fuse is labeled just "water pump" but it also protects the stove hood fan and light, and the red indicator lights on the monitor panel. These are the irritating things that get to you. Why doesn't Thor label the fuses correctly? Who knows! Anyway your tip led me to the solution. Thanks again.
__________________
Finskidog is offline   Reply With Quote
Old 10-28-2018, 04:49 AM   #5
Member
 
Brand: Thor Motor Coach
Model: Vegas 24.1
State: Washington
Posts: 63
THOR #10717
Great glad you got it figured out. If the fuse blows again you might have a loose wire. The problem i had was intermittent because the wire in the fuse box was not right enough. Glad you got it fixed.
__________________
gte534j is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 05:02 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×