RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
 

Go Back   Thor Forums > Thor Community Forums > Introduce Yourself | Say Hello
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 03-24-2017, 03:29 PM   #1
Junior Member
 
Brand: Thor Motor Coach
Model: Four winds 26b
State: Illinois
Posts: 29
THOR #6565
What now?

So picked our first brand new 26B last Saturday and wasn't a bad 3hr. drive home besides being a little windy. The following day took the wife and son plus granddaughter for a short drive then it starts, wrench light, check engine light comes on plus tow haul cruise control stop working and runs runs horrible. Next morning start up, chugged like a old steam engine for about 3minutes until it started to smooth out. It's at the Ford dealer for the last 2 days and they still can't find out what's going on, hopefully today they will figure it out. Notified Thor just in case it's there problem. Never have owned a brand new rv until now and I'm starting to think I should have stuck with used. I did get our stuff loaded in but haven't been able to even get the beer loaded in the fridge and camp yet. I think it's in good hands hopefully the problems will be resolved soon. Sorry just needed to rant for a minute.
__________________

__________________
rfd2117 is offline   Reply With Quote
Old 03-24-2017, 04:12 PM   #2
Axis/Vegas Enthusiast
 
JamieGeek's Avatar
 
Brand: Thor Motor Coach
Model: Axis 24.1
State: Michigan
Posts: 9,168
THOR #1150
Tow/haul and cruise not running along with engine not running right points to the engine computer going wonky (yeah a technical term) or some wires coming loose/off sensors.

Ford dealer should be able to get that straightened out.
__________________

__________________
2014 Thor Axis 24.1
2018 Chevy Bolt
blog - https://spareelectrons.wordpress.com/
JamieGeek is offline   Reply With Quote
Old 03-24-2017, 04:50 PM   #3
Junior Member
 
Brand: Thor Motor Coach
Model: Four winds 26b
State: Illinois
Posts: 29
THOR #6565
Quote:
Originally Posted by JamieGeek View Post
Tow/haul and cruise not running along with engine not running right points to the engine computer going wonky (yeah a technical term) or some wires coming loose/off sensors.

Ford dealer should be able to get that straightened out.
Thanks, I hoping that's all it is. The Ford service manager did mention that worse case they set the box on the chassis and screwed up the wiring which makes it a thor thing. I don't think they build the motorhome and then set the whole thing on the chassis but I wasn't going into how they build them.
__________________
rfd2117 is offline   Reply With Quote
Old 03-27-2017, 05:50 PM   #4
Junior Member
 
Brand: Thor Motor Coach
Model: Four winds 26b
State: Illinois
Posts: 29
THOR #6565
Ford dealer called and all is good, they did 3 days of diagnostic testing and turned out to be loose connections on the pcm.
__________________
rfd2117 is offline   Reply With Quote
Old 03-27-2017, 06:34 PM   #5
Senior Member
 
Brand: Thor Motor Coach
Model: Four Winds 23U
State: Illinois
Posts: 478
THOR #992
Great news enj0y your ride and safe travels.
__________________
KNMIB is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 05:03 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×